|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10945 Apache core dumps when PHP4.0.5 is activated via LoadModule
Submitted: 2001-05-17 20:57 UTC Modified: 2001-06-03 06:26 UTC
From: morgan at hecate dot pdnt dot net Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.5 OS: AIX 4.3.3 (MU8)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: morgan at hecate dot pdnt dot net
New email:
PHP Version: OS:


 [2001-05-17 20:57 UTC] morgan at hecate dot pdnt dot net
Apache-1.3.19 compiles clean under gcc-2.95.3 with:

$ ./configure --prefix=/opt/apache --enable-module=so
<junk deleted>
$ make
<junk deleted>
# make install
<junk deleted>

Apache starts cleanly and generally works fine.

PHP4.0.5 compiles clean under gcc-2.95.3 with:

$ ./configure --prefix=/opt/php --with-apxs=/opt/apache/bin/apxs --with-mysql=/opt/mysql
<junk deleted>
$ make
<junk deleted>
# make install
<junk deleted>

Howver when I stop Apache and start it back up again, it doesn't start.  It dumps core.  When I rem out the LoadModule directive for the php module in httpd.conf, Apache starts up fine.

[ FYI: it's MySQL 3.23.34a (--prefix=/opt/mysql --with-pthreads) ]

Any suggections on how to troubleshoot it ?  If you have a use for the core, I can send it to you.  More info:

AIX 4.3.3 (maintenance update 8)

Only other software installed on the system is GNU make-3.79.1 and bash-2.04.

Any help is greatly appreciated.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-17 21:49 UTC]
On systems that use glibc-2.1.x there is a bug in glibc that prevents a binary not linked against pthreads to dynamically load a shared library that is linked against pthreads.  Perhaps this problem also exists on AIX?  Try linking your Apache httpd against libpthreads.
 [2001-05-18 01:29 UTC] morgan at hecate dot pdnt dot net
Tried recompiling everything with IBM Visual Age C v5.01.  No change.  I also tried linking with the pthread library for the httpd binary, like said to try, but no luck.  Quick question: is AIX on the "supported" list ??  Is this supposed to work ??

 [2001-05-18 01:36 UTC]
There is no "supported list".  But, obviously operating systems that are more common end up getting more attention and more testing.  AIX is near the bottom of that list.
 [2001-05-18 02:07 UTC] morgan at hecate dot pdnt dot net
Somehow, I'd guessed that AIX would finish low on the "supported list".  One note, for anyone that's stuck with this config -> I installed iPlanet Web Server 4.1SP7, to see if maybe NSAPI would work, and I got problems that were much like the ones with Apache.  BUT -> when I didn't specify a web server to support, I got a "normal" binary for PHP, which I could use as a CGI interpreter.  One comment about this though, when a script starts with "#!/opt/php4/bin/php", that was displayed at the top of the web page, but what was below worked fine (in this case, "<? phpinfo(); ?>").

Any idea how to get rid of that ??  (removing the text broke the script, and I got nothing but the content of the php file with no execution).  That would give a "valid" solution for AIX people.  (I guess installing Linux on the RS6000 would work too, but that's such a pain...)

 [2001-05-18 16:28 UTC]
This behavior sounds very similar to #4630.
 [2001-05-22 06:44 UTC] morgan at hecate dot pdnt dot net
Tried the new php-4.0.6RC1 that's supposed to play nice with AIX 4.3.3.  Didn't work either.  This looks similary to #4630, but if 4.0.6RC1 fixed #4630, then I have a new problem...  Going to try a couple of other things.  Is there a reference implementation that the developers use for AIX that I can emulate ?

--Morgan Henning
 [2001-06-03 06:26 UTC]
This should be fixed in PHP 4.0.6. Please try the latest
release candidate:


PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 14:01:28 2024 UTC