php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10944 hw_info() prints garbage for server string
Submitted: 2001-05-17 19:15 UTC Modified: 2007-04-04 20:09 UTC
From: torben@php.net Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.0 Latest CVS (2001-05-17) OS: Linux 2.2.14/Mandrake 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: torben@php.net
New email:
PHP Version: OS:

 

 [2001-05-17 19:15 UTC] torben@php.net
hw_info() is printing some random garbage for the server string:

?̏**?*, localhost, 717, anonymous, 7175, 0

Looking at the source it seems that the server string is never getting set properly when the connection is made
in hg_comm.c, but I don't have time to track this down today.

Torben

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-25 09:07 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 13:05:45 2022 UTC