php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10906 mod_ssl and php oci8 interaction problem
Submitted: 2001-05-16 13:43 UTC Modified: 2001-05-17 11:01 UTC
From: dawson_j at crane dot navy dot mkil Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.5 OS: RedHat Linux 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dawson_j at crane dot navy dot mkil
New email:
PHP Version: OS:

 

 [2001-05-16 13:43 UTC] dawson_j at crane dot navy dot mkil
When building apache, ssl and php4 with oci8 support statically, and compiling everything myself, things are great.
However,

When trying  to use RedHat's built in Apache server and mod_ssl, on both RedHat version 7.0 and 7.1,
The following events happen.

Scenario 1:
Using Apache without the mod_ssl rpm installed.
Build php 4.0.5 using apxs with-oci8

This works.

Scenario 2:
Using apache with the mod_ssl rpm installed.
build php4.0.5 using apxs without-oci8
This works.

Scenario 3.
Using apache with mod_ssl rpm installed,
build php4.0.5 using apxs with-oci8

httpd dies silently, no error message.

This method is also reproducable by loading the RedHat 7.1 SRPM for php version 4.0.4pl1.
modify the spec file to include --with-oci8.
rebuild the rpm and install.

I have seen this particular problem in mailing lists, but not specifically described in detail. By trying all of 
these different combinations, I believe that something with the oci8 support is conflicting with mod_ssl.

Is this a problem of a missing -DEAPI flag?

I tried modifying the make file for it, but that didn't work either.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-17 11:01 UTC] dawson_j at crane dot navy dot mkil
libpthread problem again
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 05:05:50 2023 UTC