php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10905 ImageGif (ImagePNG) output uncompressed
Submitted: 2001-05-16 12:17 UTC Modified: 2002-01-02 13:55 UTC
From: pumuckel at metropolis dot de Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pumuckel at metropolis dot de
New email:
PHP Version: OS:

 

 [2001-05-16 12:17 UTC] pumuckel at metropolis dot de
Using the compression ob_gzhandler all HTML Pages get compressed well. But dynamic generated Images don't get compressed.

Header of the output says, it is compressed, but the data following the header isn't. So those images can't be displayed (by at least netscape)

Thanks for the patch, ;-)

 mike

PS: Don't tell me that it isn't useful to gzip images, but if you have switched compression to 'enabled' in your php.ini file and you are creating images on the fly, you'll need it to handle this case correctly.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-12 04:27 UTC] yohgaki@php.net
If you want to compress images,  use zlib extension.
 [2001-12-12 04:39 UTC] derick@php.net
Let's not make this bogus. However, please post a short reproducing example script.

Derick
 [2001-12-12 05:02 UTC] yohgaki@php.net
Ok Derick.  It would be useful for other purposes also.

Status = Feedback.

To reporter,  Could you try it on snapshot 

http://snaps.php.net/

Please provide *short* script. Thank you.
 [2002-01-02 13:55 UTC] lobbin@php.net
No feedback. Closing.
 [2002-04-14 19:40 UTC] tux at devel dot ee
it looks like its an netscape 4.x bug. i tested with zlib.output_compression (php 4.1.2) off and all gd generated images worked fine. but when the compression is On, images appeared broken... There's no problem with netscape 6x and msie 5.5/6.0. Is it possible to turn off zlib.output_compression within php script, so that we could manually decide which browsers get gzipped data?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 08:01:25 2020 UTC