php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10876 Main thread error if die placed in file which uncluded from switch-case operato
Submitted: 2001-05-15 07:48 UTC Modified: 2001-08-20 12:09 UTC
From: anton at concord dot ru Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.5 OS: WINNT 4.0 SP6 + Apache 3.12, php
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: anton at concord dot ru
New email:
PHP Version: OS:

 

 [2001-05-15 07:48 UTC] anton at concord dot ru
I use WINNT 4.0+SP6+Apache 1.3.12+php 4.0.5 as apache module
I got Apache main thread error each time, if die() or exit() function placed in file which included from switch-case operator like this:

code example

tdie.php
<?
$a=1;
switch ($a) {
  case 1:
    include("testdie.php");
    break;
}
?>

testdie.php
<?
die("qq");
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-15 08:07 UTC] anton at concord dot ru
Some comments.
It happen when Output_buffering=on only, if output_buffering=off all is ok
 [2001-07-15 13:54 UTC] zeev@php.net
Unable to reproduce under the latest CVS.  Please try a recent snapshot from www.zend.com/snapshots/ and see if the problem persists.
 [2001-08-20 12:09 UTC] sniper@php.net
No feedback. Reopen if you still have this problem
with PHP 4.0.7 (soon to be released) or with latest CVS 
snapshot.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 03:01:24 2021 UTC