php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10874 getcwd() always return empty string.
Submitted: 2001-05-15 05:42 UTC Modified: 2001-05-16 07:53 UTC
From: artem at osp dot ru Assigned:
Status: Closed Package: Directory function related
PHP Version: 4.0.5 OS: Linux Redhat7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: artem at osp dot ru
New email:
PHP Version: OS:

 

 [2001-05-15 05:42 UTC] artem at osp dot ru
<?php
 echo "'".getcwd()."'";
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-15 05:48 UTC] swm@php.net
Cannot recreate this on any system with current CVS.
 [2001-05-15 05:55 UTC] derick@php.net
I can't reproduce this too.

What SAPI are you using (Which webserver, and CGI or Module)?

Derick
 [2001-05-15 06:26 UTC] artem at osp dot ru
Apache, static module.

see result of this script

<?php
 echo "pwd: '".`pwd`."'<br>";
 echo "getcwd: '".getcwd()."'<br>";
 phpinfo();
?>

on http://www2.osp.ru/~artem/t8.php
 [2001-05-16 00:29 UTC] sniper@php.net
I can't reproduce this either.
Please try latest snapshot from http://snaps.php.net/

--Jani

 [2001-05-16 03:46 UTC] artem at osp dot ru
Ok. I tryed latest snapshot from http://snaps.php.net/
It doesn't have this bug.
I recompiled 4.0.5 - it has bug.

see difference: 
http://www2.osp.ru/~artem/t8/t8-dev.html
http://www2.osp.ru/~artem/t8/t8-405.html

 [2001-05-16 07:53 UTC] derick@php.net
Ok, so it fixed then.

Derick
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 15:01:23 2020 UTC