php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10855 File Upload using dll - more info
Submitted: 2001-05-14 12:35 UTC Modified: 2001-05-14 20:18 UTC
From: martin at center dot cc Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.0.5 OS: Win98
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: martin at center dot cc
New email:
PHP Version: OS:

 

 [2001-05-14 12:35 UTC] martin at center dot cc
To ID#8210
This problem seems not only win2k related. 
I am having the same problem on win98 uploading jpg images,
CGI works dll doesn't.
(Apache 1.3.19)

Maybe it will help to add that the fileupload only returns the characters
until the first & - then it stops so I'm assuming that the problem could be
in there.
Here is how the image file starts:
????&')*)-0-(0%()(?
what I get after the upload is just
????

Martin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-14 13:12 UTC] martin at center dot cc
ignore the & part - it returns only a part of the image which differs in length when using different images but is never complete.

 [2001-05-14 20:18 UTC] sniper@php.net
This is not a bug. You have to tell windows that it
should open the file as binary. Read the manual page
for fopen() again. 

--Jani

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 01:01:23 2021 UTC