php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10812 libtool syntax error
Submitted: 2001-05-11 06:42 UTC Modified: 2001-05-11 18:22 UTC
From: morten at nilsen dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.0 Latest CVS (2001-05-11) OS: Linux 2.4.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: morten at nilsen dot com
New email:
PHP Version: OS:

 

 [2001-05-11 06:42 UTC] morten at nilsen dot com
root@Tenchi /usr/src/php4# make
Making all in Zend
make[1]: Entering directory `/usr/src/php4/Zend'
flex -Pzend -ozend_language_scanner.c -i
./zend_language_scanner.l
bison -y -p zend -v -d ./zend_language_parser.y -o
zend_language_parser.c
/bin/sh ../libtool --silent --mode=compile gcc
-DHAVE_CONFIG_H -I. -I. -I../main   -DLINUX=22
-DMOD_SSL=208102 -DEAPI -DUSE_EXPAT -DSUPPORT_UTF8
-DXML_BYTE_ORDER=12  -g -O2 -c zend_language_scanner.c
../libtool: line 1292: syntax error near unexpected token
`<<<<<'
../libtool: line 1292: `<<<<<<< ltmain.sh'
make[1]: *** [zend_language_scanner.lo] Error 2
make[1]: Leaving directory `/usr/src/php4/Zend'
make: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-11 06:53 UTC] derick@php.net
Please use a fresh checkout of the Zend directory, as this problem does not occur for me.
 [2001-05-11 18:04 UTC] morten at nilsen dot com
It appears that the problem was me not knowing I had to do a
separate buildconf and configure for Zend and TSRM.

perhaps mentioning this in the CVS howto-thingie?
 [2001-05-11 18:22 UTC] sniper@php.net
You DO NOT have to do separate buildconf/configure for
Zend and TSRM. But you do have to get fresh checkouts
of them all since it seems like they are borked for you.

Only thing you have to do is have them under php4/ directory..ie. php4/Zend/ and php4/TSRM

And run './cvsclean ; ./buildconf' always.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 02 10:01:23 2020 UTC