php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10741 ereg "-" problem only on 4.05 - critical!
Submitted: 2001-05-08 20:30 UTC Modified: 2001-05-08 22:30 UTC
From: koester at x-itec dot de Assigned:
Status: Closed Package: PCRE related
PHP Version: 4.0.5 OS: FreeBSD 4.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: koester at x-itec dot de
New email:
PHP Version: OS:

 

 [2001-05-08 20:30 UTC] koester at x-itec dot de
After updating from 4.04x to 4.05 i noticed a problem with regular expressions.

regular expression:

0-9a-zA-Z[:space:]\-\@\&\=\?\_\+\/\:\.\;

should normally find this:
http://p.moreover.com/cgi-local/page?index_humanrights+rss

using ereg(i) command - but no chance.

If I delete this: "-" (cgi-local to cgilocal) it works.

The regular expression worked with 4.04x and since updating it does not work any longer.

I think its a "critical" bug.

Interesting is that I have only probs with "-", but it seems to be that there are some more problems with another regular expression I had no time to analyze yet.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-08 22:30 UTC] koester at x-itec dot de
ok now the interesting part. As mentioned in the regex dox, "use - at the beginning or at the end.." it works.

So far, so good - but, the regular expression worked before without this (necessary) change.

Interesting point. After rewriting some of my sources now everything works again, sorry for bothering anyone.

Maybe it has something todo with my FreeBSD update from 4.2 to 4.3 (regex lib?) I don?t know.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 26 09:01:25 2019 UTC