php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10691 PHP crashes when using ob_-functions
Submitted: 2001-05-06 11:15 UTC Modified: 2001-10-19 10:59 UTC
From: mail at martin-jansen dot de Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.5 OS: Windows 2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mail at martin-jansen dot de
New email:
PHP Version: OS:

 

 [2001-05-06 11:15 UTC] mail at martin-jansen dot de
Using the following script, PHP 4.0.5 crashes under
Windows 2000:

<?php
ob_start();

function foo($message = "") {
    if ($message == "")
        exit;
}

foo();

ob_end_flush();
?>

- Martin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-19 10:59 UTC] sander@php.net
Please upgrade to the latest version. Reopen if the problem still occurs.

I'm unable to reproduce this on Win2K with 4.0.7RC3.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 16:03:35 2021 UTC