php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10628 request_config is bogus
Submitted: 2001-05-03 03:56 UTC Modified: 2001-05-28 02:19 UTC
From: emile at iris-advies dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.5 OS: Linux (Debian Sid)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: emile at iris-advies dot com
New email:
PHP Version: OS:

 

 [2001-05-03 03:56 UTC] emile at iris-advies dot com
Using apache 1.3.19-1 and php4.0.4.5rc6-2 (debian packages)

$ ./ext_skel --extname=apdebug

Apply this patch:

diff -ur apdebug.org/apdebug.c apdebug/apdebug.c
--- apdebug.org/apdebug.c       Thu May  3 09:44:19 2001
+++ apdebug/apdebug.c   Thu May  3 09:45:05 2001
@@ -74,6 +74,9 @@
 /* Remove if there's nothing to do at request start */
 PHP_RINIT_FUNCTION(apdebug)
 {
+       request_rec *r;
+   r = ((request_rec *) SG(server_context));
+   fprintf(stderr, "APDEBUG, request_config=%#lx\n", 
r->request_config);
        return SUCCESS;
 }

$ phpize
$ CFLAGS="$CFLAGS -DHAVE_APDEBUG=1 -DCOMPILE_DL_APDEBUG=1" 
./configure --enable-apdebug
$ make; make install

add extension=apdebug.so to php.ini

We've had numerous reports (on my own machine, but also on 
SuSE, Redhat and others) where request_config would always 
be 0x10000, and verifiably have another (sane) value in 
other apache modules during the same request. This is the 
only dynamic extension loaded, other than the built-in 
extensions that the debian php4 package provides.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-03 04:01 UTC] emile at iris-advies dot com
Forgot: need to edit config.m4 to comment out the enable 
stuff of course.

 [2001-05-27 23:58 UTC] sniper@php.net
No idea what this report is about. Please submit a new
bug report with the PROBLEM described.

--Jani

 [2001-05-28 02:19 UTC] emile at iris-advies dot com
The problem is that the extension we write needs to access request_config and when we dereference it it segfaults, since it is always the bogus value 0x10000
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 06:01:22 2020 UTC