|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10614 make fails
Submitted: 2001-05-02 12:51 UTC Modified: 2001-05-02 13:18 UTC
From: dping28 at hotmail dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.5 OS: Mandrake 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: dping28 at hotmail dot com
New email:
PHP Version: OS:


 [2001-05-02 12:51 UTC] dping28 at hotmail dot com
I was following the instructions on devshed to install php
and when i ran make it went a while then drops given this:

/bin/sh ../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../main  -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12 -g -02 -c zend_hash.c
zend_hash.c: In function `zend_hash_minmax':
zend_hash.c:1233: Internal error: Segmentation fault.
Please submit a full bug report.
make[1]: *** [zend_hash.lo] Error 1
make[1]: Leaving directory `/tmp/download/php-4.0.5/Zend'
make: *** [all-recursive] Error 1

Any ideas? Am I doing something wrong? 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-02 13:07 UTC]
Do you get the same error in the same place
when you run again?

The only reasons that made gcc bail out with
a segmentation fault during compilation 
i came across within years were faulty ram
and overheated CPUs

In this case you will experience segfaults
from gcc in random places, typing make 
again and again finally gets you through
the process (although you should not trust
the result)

 [2001-05-02 13:13 UTC] dping28 at hotmail dot com
Hmm that may have been it I ran it again and it worked.. thanks for the help..
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Mar 28 06:03:37 2023 UTC