php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10589 buildconf not compatible with Gnu Libtool 1.4
Submitted: 2001-05-01 15:58 UTC Modified: 2001-06-29 14:32 UTC
From: TheBOFH at nc dot rr dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Latest CVS (01/05/2001) OS: RH Linux 6.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: TheBOFH at nc dot rr dot com
New email:
PHP Version: OS:

 

 [2001-05-01 15:58 UTC] TheBOFH at nc dot rr dot com
After the problems installing 4.0.5, I got the latest CVS.

Running buildconf told me I needed libtool installed.  Went to Gnu, got the latest (1.4) and installed it.

buildconf now reports:
buildconf: libtool version 1.4 found.
           You need libtool version 1.3.3 or newer installed
           to build PHP from CVS.
make: *** [buildmk.stamp] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-01 20:43 UTC] sniper@php.net
Works for me just fine. Try doing './cvsclean ; ./buildconf'

--jani

 [2001-05-01 21:13 UTC] TheBOFH at nc dot rr dot com
[root@gecko /root]# cd /usr/src/php4
[root@gecko php4]# ./cvsclean; ./buildconf
buildconf: checking installation...
buildconf: autoconf version 2.13 (ok)
buildconf: automake version 1.4 (ok)
build/buildcheck.sh: test: integer expression expected before -ge
buildconf: libtool version 1.4 found.
           You need libtool version 1.3.3 or newer installed
           to build PHP from CVS.
make: *** [buildmk.stamp] Error 1
 [2001-05-02 07:47 UTC] andi@php.net
Any reason why this was closed?
 [2001-05-02 23:44 UTC] sniper@php.net
Fixed in CVS. Thanks for catching this!

--Jani

 [2001-05-09 11:18 UTC] sniper@php.net
Reopened. There are some problems with libtool 1.4 still
so we propably won't support for it in 4.0.6. 

Marked to be fixed before 4.0.7.

--Jani


 [2001-06-28 05:37 UTC] jmoore@php.net
This has been fixed has it not?? Libtool 1.4 works fine for me with latest CVS. CLosing
 [2001-06-28 15:14 UTC] sniper@php.net
No, the libtool 1.4 is seriously bugged..

 [2001-06-29 14:32 UTC] sniper@php.net
There is already another bug report about the other problems. The issue reported in this one is fixed. 


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 20:05:45 2022 UTC