php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10443 PHP Crashes when it opens complicated pages
Submitted: 2001-04-22 12:40 UTC Modified: 2001-09-22 12:22 UTC
From: charlie at charliedyson dot net Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.4pl1 + 4.05 OS: Linux 2.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: charlie at charliedyson dot net
New email:
PHP Version: OS:

 

 [2001-04-22 12:40 UTC] charlie at charliedyson dot net
PHP just crashes when it opens particularly complicated 
pages. When I'm hacking at a page, it I add another loop, 
or insert a few more lines of code in somewhere, it'll 
just crash.

This bug is _not_ caused by the invocation of any one 
function, the use of any one particular syntax element or 
feature. It is caused by excessively complicated pages. 
Therefore, it's probably some memory-related bug in php's 
internals. Apache logs report that the server dies with 
SIGSEGV. The only way I think you'll work out what this is 
is by looking at a core file, or if I send you a suspect 
file. I can't seem to get php to dump one (tried httpd -X 
in /tmp, but it doesn't work). Any ideas? I submitted this 
bug before, but I was told the CVS version had it fixed. 
I've used a CVS snapshot, and that didn't fix it.

Thanks in advance,

Charlie Dyson - charlie@charliedyson.net

( By the way, PHP is the best web-related tool I have ever 
come across and it's made web-development a lot easier for 
everyone. Thanks. )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-25 16:24 UTC] charlie at charliedyson dot net
The following is the PHP backtrace and GDB output you 
requested. Sorry it took
so long, it involved recompiling apache and php to get a 
non-stripped executable.
Note that exactly the same output occurs every time the 
server crashes on the page. If required, I could send you 
the page in question, but it includes loads of other files 
as well.

Is the bug fixed in the 4.0.5 release?

Heres the output:
Program received signal SIGSEGV, Segmentation fault.
0x80deb80 in _zval_ptr_dtor (zval_ptr=0xbfffd368) at 
zend_execute_API.c:259
259		(*zval_ptr)->refcount--;

Backtrace:

#0  0x80deb80 in _zval_ptr_dtor (zval_ptr=0xbfffd368) at 
zend_execute_API.c:259
#1  0x811192b in zend_switch_free (opline=0x8280abc, 
Ts=0xbfffd0a8)
    at ./zend_execute.c:236
#2  0x810eb34 in execute (op_array=0x821a4a4) at 
./zend_execute.c:1855
#3  0x810f690 in execute (op_array=0x820e5fc) at 
./zend_execute.c:2063
#4  0x80e5f4b in zend_execute_scripts (type=8, 
file_count=3) at zend.c:729
#5  0x807cbeb in php_execute_script 
(primary_file=0xbffff66c) at main.c:1221
#6  0x80f24bb in apache_php_module_main (r=0x820170c, 
display_source_mode=0)
    at sapi_apache.c:89
#7  0x807a306 in send_php ()
#8  0x807a33e in send_parsed_php ()
#9  0x8117d79 in ap_invoke_handler ()
#10 0x812c1df in process_request_internal ()
#11 0x812c24a in ap_process_request ()
#12 0x8123406 in child_main ()
#13 0x81235c1 in make_child ()
#14 0x812373c in startup_children ()
#15 0x8123d9d in standalone_main ()
#16 0x81245cc in main ()
#17 0x400de213 in __libc_start_main (main=0x8124234 
<main>, argc=2, 
    argv=0xbffff8fc, init=0x8061c20 <_init>, 
fini=0x815e010 <_fini>, 
    rtld_fini=0x4000ac30 <_dl_fini>, stack_end=0xbffff8f4)
    at ../sysdeps/generic/libc-start.c:90


 [2001-06-02 17:05 UTC] charlie at charliedyson dot net
I have downloaded and testted PHP 4.0.5, and the bug is 
still there. I'll get a backtrace if you need one.

Also, my last comment has not been replyed to. Have I been 
forgotten about?

Thanks for your help,

Charlie Dyson - charlie@charliedyson.net

 [2001-08-31 11:27 UTC] sander@php.net
Please try again with 4.0.6 and/or the latest CVS.
 [2001-09-22 11:44 UTC] derick@php.net
No feedback, please reopen is the problem is not fixed.

Derick
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Oct 04 11:01:25 2023 UTC