php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10405 pdf: Unable to initilize module
Submitted: 2001-04-19 12:00 UTC Modified: 2001-04-29 05:34 UTC
From: john at neutralize dot com Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0.4pl1 OS: Windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at neutralize dot com
New email:
PHP Version: OS:

 

 [2001-04-19 12:00 UTC] john at neutralize dot com
I have downloaded pdflib-4.0.0-Windows so I can pdf things in php.

The installation instructions are as follows:

"For building the PDFlib PHP binding you must have to the directory "ext/pdf" to your PHP source tree. Then build php_pdf.dll."

I did not understand this completely so have probably hashed the configuration up and as there is no other instructions I did my best.

I copied the directory pdf indicated above to my wwwroot (as I am using pws for testing) ie C:\Inetpub\wwwroot\pdf (with files in) and to get it to pick up the dll I created C:\Inetpub\wwwroot\dll to place php_pdf.dll in and uncommented extension=php_pdf.dll in php.ini along with pointing to the dll directory by uncommenting extension_dir="C:\Inetpub\wwwroot\dll"

This all seemed really messy and obviously not configured correctly but the readme file did not give any more explanations.

The full error message that appears now when I try to load any php page is as follows:

pdf: Unable to initilize module
Module compiled with debug=0, thread-safety=1, module API=20001222
PHP complied with debug=0, thread-safety=1, module API=20001214
These options need to match

With the unix installation instructions the c++ code needs compiling but does not mention it for Windows, does this mean I don't have to make the c++ code?

I will be grateful for any help on resolving this.

Thanks

John

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-29 05:34 UTC] jmoore@php.net
you need to compile your php.exe/.dll with the same sources as your pdf.dll. this is the cause of your error message.

- James
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 23:01:28 2024 UTC