php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #10377 PHP forces illegal HTML
Submitted: 2001-04-18 09:44 UTC Modified: 2001-04-18 09:54 UTC
From: have at none dot com Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0.4pl1 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: have at none dot com
New email:
PHP Version: OS:

 

 [2001-04-18 09:44 UTC] have at none dot com
$HTTP_GET_VARS and $HTTP_POST_VARS force us to use illegal HTML. This is because we have to add "[]" after a checkbox name if we want to access all values.

Suggested fixes:

1. $HTTP_GET_VARS could return an array.
2. Create environment variables $HTTP_GET/POST which includes the parameters in the standard way (like "name=value&name2=value2" etc.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-18 09:54 UTC] derick@php.net
1. $HTTP_GET_VARS is an array (try var_dump ($HTTP_GET_VARS));
2. You can get the whole query string: $HTTP_SERVER_VARS["QUERY_STRING"];

and

3. You don't need to use the [], it's up to you how you use it. It merely gives you a nice function.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 13 22:01:29 2024 UTC