php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10368 add 0 (zero) in function "date"
Submitted: 2001-04-17 18:09 UTC Modified: 2001-04-29 11:25 UTC
From: roger at wzero dot com dot br Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.4pl1 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: roger at wzero dot com dot br
New email:
PHP Version: OS:

 

 [2001-04-17 18:09 UTC] roger at wzero dot com dot br
$ds[1]=dia2s(date( "D", mktime(0,0,0,$data["mon"],$data["mday"] +0,$data["year"])));


Adding +0 to a date returns the next day. it should return today!

Adding +1 or -1 works fine!

thanks,

Roger

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-29 11:25 UTC] derick@php.net
I could not reproduce this with PHP-4.0.5RC6. What data is in your $data array? And what does the dia2s() function do?
Please reopen this report with a script that we can try to see if it's a bug, or just a problem with your PHP code.

Derick
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 14:05:47 2022 UTC