php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10358 InterBase module
Submitted: 2001-04-17 03:42 UTC Modified: 2001-04-17 03:54 UTC
From: n dot chansard at cema-france dot fr Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.4pl1 OS: Win 2K
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: n dot chansard at cema-france dot fr
New email:
PHP Version: OS:

 

 [2001-04-17 03:42 UTC] n dot chansard at cema-france dot fr
It appears that the connection is good (no msg of warning or errors) but the function ibase_query() gives a warning like:

InterBase module: 0 is not link or transaction index

source:

        <?
		$ib_link = ibase_connect("\\\\SPDCCPI01\C:\_BASES\INTRANET.GDB", "SYSDBA", "ib") || die(exit());
		print ("IB_LINK  : $ib_link<BR>\n");
		$ib_query	= "select * from servic";
		print ("IB_QUERY : $ib_query<BR>\n");
		$ib_result	= ibase_query(0, $ib_query);
		ibase_close();
	?>

I can't do less... heelp!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-17 03:54 UTC] ab@php.net
Does this
$ib_result = ibase_query(0, $ib_query);
correct? Seems that there should be $ib_link instead 0.
If this isn't typo, re-open bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 04:05:54 2022 UTC