|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10345 unlink ignores permissions
Submitted: 2001-04-16 11:15 UTC Modified: 2001-04-30 02:10 UTC
From: sascha at rizzt dot 2y dot net Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.0.1pl2 OS: redhat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
50 + 27 = ?
Subscribe to this entry?

 [2001-04-16 11:15 UTC] sascha at rizzt dot 2y dot net
unlink seems to run as root.
i have set file permissions to 444 (owner root) and tried to open this file for writing from a script. php said 'permission denied'. then i tried to unlink this file with success.



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-30 02:10 UTC]
This is not a bug but how the filesystem works. Permissions for erasing a file is according to the permissions on the directory and not the file.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 06:05:54 2023 UTC