|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #1027 fprintf() please
Submitted: 1999-01-05 04:09 UTC Modified: 2002-01-09 10:02 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: smr at csc dot dk Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: smr at csc dot dk
New email:
PHP Version: OS:


 [1999-01-05 04:09 UTC] smr at csc dot dk
Quite often my PHP3-scripts take input from the user, and writes it into a file. I can do


but it really looks ghastly. Fprintf would be nice to have.

I would also suggest that you take all the stdio-derived functions which is dispersed throughout the manual (in Filesystem and Strings) and collect them in a new section called "File I/O" or equivalent.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-10 12:40 UTC]
still no fprintf. refiled against 4.0.
 [2001-02-10 12:55 UTC]
really moved to 4.0 this time.
 [2001-07-22 12:27 UTC]
Is fprintf going to be added or should this request be closed?
 [2002-01-09 10:02 UTC]
was duped by 14949 which is more descriptive ;)
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC