|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10196 pspell functions no longer work
Submitted: 2001-04-05 22:12 UTC Modified: 2001-04-10 20:42 UTC
From: jplock at bigfoot dot com Assigned:
Status: Closed Package: Pspell related
PHP Version: 4.0.4pl1 OS: FreeBSD v4.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jplock at bigfoot dot com
New email:
PHP Version: OS:


 [2001-04-05 22:12 UTC] jplock at bigfoot dot com
The Pspell functions no longer work after upgrading to pspell 0.12 and aspell 0.33. I know you have added the pspell author's recommendation to interface with the old functions but that didn't seem to help at all. Thanks.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-05 22:22 UTC] jplock at bigfoot dot com
pspell_new_config() at least is not returning a link value.
 [2001-04-06 14:25 UTC]
Would you mind adding some example script (short) which can
be used to reproduce this? As it works for me just fine.

(with latest CVS that is)

Try also the latest snapshot from


 [2001-04-06 15:38 UTC] jplock at bigfoot dot com
Here is a bit of sample code:

$pspell_config = pspell_config_create("en");
$pspell_link = pspell_new_config($pspell_config);

$pspell_link does not return any value it seems.
 [2001-04-06 22:11 UTC]
I can't reproduce this with latest CVS. Please try the snapshot and if that doesn't work, reopen this bug report.


 [2001-04-06 22:53 UTC] jplock at bigfoot dot com
It wouldn't have anything to do with the sablotron xslt extension i also have compiled in would it? I remember reading a post on the dev list that someone had a problem with pspell and sablotron and how they wouldn't both work when compiled in together.

here's my configure line if that helps:
./configure --with-apache=../apache_1.3.19 --with-mysql=/usr/local --with-png-dir=/usr/local --with-jpeg-dir=/usr/local --with-gd=/usr/local --enable-bcmath --enable-trans-sid --disable-pear --disable-posix --with-iconv=/usr/local --with-expat-dir=/usr/local --with-sablot=/usr/local --enable-inline-optimization --enable-sablot-errors-descriptive --enable-memory-limit --disable-short-tags --with-imap --with-zlib=/usr/local --with-pspell=/usr/local --with-crack=/usr/local
 [2001-04-06 22:54 UTC] jplock at bigfoot dot com
I have also downloaded the latest CVS and I get the same problem.
 [2001-04-09 20:21 UTC]

First, make sure you remove the old pspell and aspell installation (I see you upgraded it).

Install the new version, go to pspell-.12/examples, build one of their examples, e.g. 'make example-c', and try to run it as './example-c en', and make sure you can check words, get suggestions, etc. If it bombs around here, it is aspell/pspell problem.

Otherwise make sure you have a new snapshot (php404pl1 is too old) and tell me what exactly does not work (does apache segfault, or what?)

No, it shouldn't have anything to xslt extension, at least, not that I know of any issues. When in doubt, recompile php with pspell support only and test.

Tell me if it worked:)


 [2001-04-10 15:54 UTC] jplock at bigfoot dot com
Ok, it seems to be a problem with the aspell/pspell freebsd ports collection. They aren't building each other correctly or something because when I run your example-c program, it says it can't load the aspell module. I'll play around with it some more and see if i can make it work. thanks again for your help.
 [2001-04-10 20:42 UTC]
Problem with pspell/aspell itself. Reopen if you
get them work but not work with PHP..


PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC