php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10161 base64_decode doesn't work correctly
Submitted: 2001-04-04 11:14 UTC Modified: 2001-04-04 12:20 UTC
From: kenji at earthlink dot net Assigned:
Status: Closed Package: *URL Functions
PHP Version: 4.0.4pl1 OS: Linux 2.2.12
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kenji at earthlink dot net
New email:
PHP Version: OS:

 

 [2001-04-04 11:14 UTC] kenji at earthlink dot net
Although base64_encode("960") produces the string "OTYw", 
base64_decode("OTYw") doesn't produce "960".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-04 11:37 UTC] sniper@php.net
This works for me just fine:

<?php
echo base64_encode("960");
echo "\n";
echo base64_decode("OTYw");
?>

It prints out "OTYw" and "960".

960 as ninesixzero.

This is with latest CVS. You can try the latest snapshot
from http://snaps.php.net/ to verify.

--Jani

 [2001-04-04 12:01 UTC] sniper@php.net
Why did you change this to open without giving any feedback?

--Jani

 [2001-04-04 12:01 UTC] sniper@php.net
Why did you change this to open without giving any feedback?

--Jani

 [2001-04-04 12:07 UTC] kenji at earthlink dot net
couldn't reproduce it anymore :)
 [2001-04-04 12:20 UTC] kenji at earthlink dot net
couldn't reproduce it anymore :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 13:01:23 2020 UTC