php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10106 Garbage files created when trying to load an extension which doesn't exist(?)
Submitted: 2001-04-01 22:51 UTC Modified: 2001-05-04 14:35 UTC
From: nick at loman dot net Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.4pl1 OS: Red Hat Linux 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nick at loman dot net
New email:
PHP Version: OS:

 

 [2001-04-01 22:51 UTC] nick at loman dot net
The line:

extension=satellite.so

in /usr/local/lib/php.ini causes garbage files being created in root (/) directory:
e.g.

-rw-rw-r--   1 root     root         2184 Mar 30 14:05 P}5@P}5@`?
-rw-rw-r--   1 root     root          364 Apr  2 02:45 P?*@P?*@@?
-rw-rw-r--   1 root     root          182 Mar 30 14:31 P?*@P?*@`?
-rw-rw-r--   1 root     root          182 Mar 30 14:57 ]???t?.?

Contents of file looks like:

[25-Mar-2001 01:50:18] PHP Warning:  Unable to load dynamic library './satellite.so' - ./satellite.so: cannot open shared object file: No such file or directory in Unknown on line 0
[26-Mar-2001 00:50:28] PHP Warning:  Unable to load dynamic library './satellite.so' - ./satellite.so: cannot open shared object file: No such file or directory in Unknown on line 0
[26-Mar-2001 10:58:29] PHP Warning:  Unable to load dynamic library './satellite.so' - ./satellite.so: cannot open shared object file: No such file or directory in Unknown on line 0

php info:
'./configure' '--with-apache=../apache_1.3.14' '--enable-track-vars' '--enable-ftp' '--with-gd=/home/nick/graph/gd-1.8.3' '--with-msql' '--with-mysql=/var/lib/mysql' '--with-xml=../expat/xmlparse' '--enable-wddx' '--enable-bcmath' '--with-sybase=/opt/sybase-11.9.2' '--enable-sockets' '--without-imap-ssl'

php ini file (error/log section)

error_reporting =       E_ALL & ~E_NOTICE               ; Show all errors except for notices
display_errors  =       On      ; Print out errors (as a part of the output)
                                                ; For production web sites, you're strongly encouraged
                                                ; to turn this feature off, and use error logging instead (see below).
                                                ; Keeping display_errors enabled on a production web site may reveal
                                                ; security information to end users, such as file paths on your Web server,
                                                ; your database schema or other information.
display_startup_errors = On             ; Even when display_errors is on, errors that occur during
                                                                        ; PHP's startup sequence are not displayed.  It's strongly
                                                                        ; recommended to keep display_startup_errors off, except for
                                                                        ; when debugging.
log_errors              =       On      ; Log errors into a log file (server-specific log, stderr, or error_log (below))
                                                ; As stated above, you're strongly advised to use error logging in place of
                                                ; error displaying on production web sites.
track_errors    =       Off     ; Store the last error/warning message in $php_errormsg (boolean)
;error_prepend_string = "<font color=ff0000>"   ; string to output before an error message
;error_append_string = "</font>"                ; string to output after an error message
;error_log      =       /tmp/php_errors ; log errors to specified file
error_log       =       syslog          ; log errors to syslog (Event Log on NT, not valid in Windows 95)
warn_plus_overloading   =       Off             ; warn if the + operator is used with strings

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-02 06:40 UTC] sniper@php.net
I can't reproduce this with latest CVS. Please try the latest snapshot from http://snaps.php.net/

--Jani

 [2001-05-04 14:35 UTC] jmoore@php.net
No feedback. Closing
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Mar 02 00:01:28 2024 UTC