|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10085 socket support seems not loaded
Submitted: 2001-03-31 00:48 UTC Modified: 2001-05-01 08:50 UTC
From: brandon at seed dot net dot tw Assigned:
Status: Closed Package: Sockets related
PHP Version: 4.0.4pl1 OS: Mandrake Linux 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
45 - 43 = ?
Subscribe to this entry?

 [2001-03-31 00:48 UTC] brandon at seed dot net dot tw
When I use default installed php package (php-4.0.3pl1) on
Mandrake 7.2 (default kernel 2.2.17), it lacks socket support, then I downloaded php4.0.4pl1 and compiled a 
self-contained module, it works fine!
but since php 4.0.3pl1 has some bugs,therefore, I update to 
4.0.0pl1 as suggested. Then each time I tried to call 
socket() function, it always says "call to undefined function socket()"
I recompile the self-contained module, it still doesn't work
ps.I have enabled in php.ini
strangely enough, still works fine!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-31 16:59 UTC]
What was the configure line you used to configure php4?


 [2001-05-01 08:50 UTC]
No feedback please try again with 4.0.5 and check you have the correct configure options by running ./configure --help and choose the ones you want.

- James
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 02:03:41 2022 UTC