php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10060 startup error msg format
Submitted: 2001-03-29 11:24 UTC Modified: 2002-08-22 11:21 UTC
From: cynic@php.net Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0 Latest CVS (29/03/2001) OS: NT 5 SP 1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cynic@php.net
New email:
PHP Version: OS:

 

 [2001-03-29 11:24 UTC] cynic@php.net
I don't know if this is an Apache or PHP error, but it looks like PHP doesn't pass startup error messages to Apache for logging (as expected):
my error.log contains this:
PHP:  Error parsing browscap.ini on line 6294
whereas it should read:
[Tue Mar 27 13:18:43 2001] [<errlevel>] [client 123.456.789.012] PHP:  Error parsing browscap.ini on line 6294

php4-200103280545 as DSO
apache-1.3_20010328111201

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-03 22:31 UTC] sniper@php.net
If I understood correctly the sources, the error logging
is set to the apache logger when the sapi module is started.
And AFAIK, that happens AFTER all modules are loaded/started.

Someone correct me if I'm wrong.

--Jani

 [2002-08-22 11:21 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 05:01:23 2020 UTC