php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10027 HTTP_REFERER
Submitted: 2001-03-27 11:31 UTC Modified: 2002-03-07 06:15 UTC
From: brad at youreshop dot com Assigned:
Status: Closed Package: *Web Server problem
PHP Version: 4.0.4pl1 OS: Linux Redhat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brad at youreshop dot com
New email:
PHP Version: OS:

 

 [2001-03-27 11:31 UTC] brad at youreshop dot com
Linking to a phpinfo() page should give a valid HTTP_REFERER value, however, I don't see it. The only thing I see remotely close to that is:

HTTP_WEFERER
                       WCONEUQZAAFXISHJEXXIMQZUIVOTQNQEMSFDULHPQQWOYIYZUNNYCGPKYLEJGDGVCJVTLBXFGGMEPYOQKEDOTWFAOBUZXUWLSZLKBRNVWWCUFPEGAUTFJMVRESKPNKMBIPBARHDMNNSKVFVWRKJVZCMHVIBGDADRZFSQHYUCDDJBLVLMHAALPTCXLYRWTQTIPWIGYOKSTTZRCLBDXRQBGJSNBOHMKHJYFMYXOEAIJJPHSCRTNHGSWZIDREXCAXZOWCONEUQZAAFXISHJEXXIMQZUIVOTQNQEMSFDULHPQQWOYIYZUNNYCGPKYLEJGDGVCJVTLBXFGGMEPYOQKEDOTWFAOBUZXUWLSZLKBRNVWWCUFPEGAUTFJMVRESKPNKMBIPBARH


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-29 11:11 UTC] sniper@php.net
Works for me just fine with latest CVS. (snapshot can be found at http://snaps.php.net/ )

Which webserver are you using? Apache?

--Jani

 [2001-04-29 11:50 UTC] jmoore@php.net
No feedback.

closing
 [2002-03-07 04:19 UTC] alexleu at starglory dot com
Both windows2000 & FreeBSD 3.4 found SAME Problem With Apache! 
How to decode HTTP_WEFERER?
 [2002-03-07 06:15 UTC] sesser@php.net
HTTP_WEFERER has nothing todo with PHP its some 
data your browser gives out to the world.
 [2002-05-09 08:38 UTC] mn at red1 dot net
I experienced the same problem using PHP4.2.0 (win32) with Apache on WinME.
On the phpinfo() page HTTP_REFERER was shown as HTTP_WEFERER with a value of a string of letters.

When I disabled "Norton Internet Security" the problem disappeared. 

What is more, scripts on a remote server which were reliant on getting data from HTTP_REFERER would not run with "NIS" enabled.

Did you have a similar programme running?
 [2003-10-14 14:01 UTC] paul at bladetechnology dot co dot uk
The last comment was correct. It's caused by one of the Norton products (Norton Personal Firwall in my case) changing the HTTP_REFERER header into HTTP_WEFERER (elmer fudd?) and encrypting it.  You can solve this by creating a rule in the firewall software to pass unaltered headers to named sites.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 01:03:16 2021 UTC