php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7309 configure fails on apxs, even though it's correct
Submitted: 2000-10-18 08:14 UTC Modified: 2000-10-20 10:37 UTC
From: vegard at svanberg dot no Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.3pl1 OS: RedHat 7 (with updates)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: vegard at svanberg dot no
New email:
PHP Version: OS:

 

 [2000-10-18 08:14 UTC] vegard at svanberg dot no
Hi.

I'm running Apache 1.3.14.  When I try to configure php, I get this
error;

# ./configure --with-apxs=/usr/local/apache/bin/apxs
[............]
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache module support via DSO through APXS... 
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
               [-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
               [-Wl,<flags>] <files> ...
       apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
       apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Sorry, I cannot run apxs. Either you need to install Perl or you need to pass the absolute path of apxs by using --with-apxs=/absolute/path/to/apxs

#


I _have_ specified apxs' location and I _have_ perl installed and I can't think of this of any other way than a bug..  I've also moved RHs buggy apxs out of the way.  What's going on?

Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-19 19:02 UTC] sniper@php.net
Try running apxs 'by hand':

/usr/local/apache/bin/apxs -q CFLAGS

You are using apache installed from rpm ?
Have you tried to compile it yourself from sources??

--Jani

 [2000-10-19 19:05 UTC] rasmus@php.net
This usually happens when you have an Apache instance that was not built with --enable-module=so
 [2000-10-20 10:37 UTC] sniper@php.net
User reported problem solved with Rasmus's advice..

--Jani
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 13:00:01 2026 UTC