php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6100 failed to use both mod_php3 and mod_php4
Submitted: 2000-08-11 02:27 UTC Modified: 2000-12-07 11:28 UTC
From: udo dot rader at profile dot co dot at Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.1pl2 OS: suse linux 6.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: udo dot rader at profile dot co dot at
New email:
PHP Version: OS:

 

 [2000-08-11 02:27 UTC] udo dot rader at profile dot co dot at
for various reasons i need both mod_php3 and mod_php4 loaded into my apache 1.3.9 as dso's.

after recompiling and reinstalling apache using mod_so now, recompiling and reinstalling php3 to use apxs and versioning and after all compiling and installing php4 i get the following strange error messages in my httpd.error_log:

-------CUT----------
PHP Warning:  Function registration failed - duplicate name - define in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - defined in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - each in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - strlen in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - strcmp in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - strcasecmp in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - error_reporting in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - leak in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - function_exists in Unknown on line 0
PHP Warning:  Basic Functions:  Unable to register functions, unable to load in Unknown on line 0
-------CUT----------

obviously php4 rejects living with php3 ...

i am able to use the php3 dso without problems, if i outcomment the loadModule command for php4 in httpd.conf,  the same applies for the php4 dso counterwise.

on the other hand the php4 only dso usage results in a "Zero Sized Reply" if i use any technology other than php4 (eg. mod_perl).

stats:
OS: suse linux 6.2
kernel: 2.2.10

Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-11 03:51 UTC] mrobinso@php.net
Did you add '--with-apxs=/path/to/apxs' and
'--enable-versioning' to the config lines for
*both* php3 and php4?

It's required by both versions.
 [2000-08-22 11:57 UTC] udo dot rader at profile dot co dot at
yes, the options i used for configure were as follows:

- php3:
---------CUT------------
./configure \
--with-mysql=/usr/local \
--enable-track-vars \
--enable-versioning \
--with-gd \
--without-imap \
--with-apxs=/usr/local/httpd.games/bin/apxs
---------CUT------------

- php4:
---------CUT------------
./configure \
--with-mysql=/usr/local \
--enable-track-vars \
--enable-versioning \
--without-gd \
--without-imap\
--with-apxs=/usr/local/httpd.games/bin/apxs
---------CUT------------

any ideas?


 [2000-11-01 09:03 UTC] sniper@php.net
Have you tried PHP4.0.3pl1 and does this
problem still exist? 

--Jani
 [2000-12-07 11:28 UTC] sniper@php.net
Reopen, if this still happens when using latest snapshot
from http://snaps.php.net/

--Jani
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 21:00:01 2026 UTC