php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5328 Unable to run php 4.0.1 or 4.0.1pl2 as CGI-BIN
Submitted: 2000-07-02 08:19 UTC Modified: 2000-08-08 08:26 UTC
From: ying at zippydesign dot com Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.1pl2 OS: Redhat Linux 6.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ying at zippydesign dot com
New email:
PHP Version: OS:

 

 [2000-07-02 08:19 UTC] ying at zippydesign dot com
I compiled PHP 4.0.1 and PHP 4.0.1pl2 as a CGI bin, but every time I access a .php page I see:

Parse error: parse error in /home/httpd/cgi-bin/php on line 314

Even a simple <? echo "Hi" ?> script will cause this error,
whereas with PHP 4.0.0 compiled with the same settings and using the same php.ini file, things were working.

The configure switches used were:

./configure \
        --disable-debug \
        --enable-force-cgi-redirect \
        --enable-discard-path \
        --enable-track-vars \
        --enable-magic-quotes \
        --with-config-file-path=/etc/httpd/conf \
        --enable-bcmath \
        --with-imap \
        --with-mysql \
        --with-pdflib=/usr/local \
        --with-gdbm

I used the php.ini-optimized file and made some changes, output from diff -b php.ini-optimized /etc/httpd/conf/php.ini shown below:

96,103d95
<
< disable_functions     =                                                               ; This direc
tive allows you to disable certain
<                                                                                                  ;
 functions for security reasons.  It receives
<                                                                                                  ;
 a comma separated list of function names.
<                                                                                                  ;
 This directive is *NOT* affected by whether
<                                                                                                  ;
 Safe Mode is turned on or off.
<
<
124c116
< max_execution_time = 30     ; Maximum execution time of each script, in seconds
---
> max_execution_time = 30     ; Maximum execution time of each script, in seconds (UNIX only)
150c142
< error_reporting       =       E_ALL & ~E_NOTICE               ; Show all errors except for notices
---
> error_reporting       =       E_ALL   ; Show all errors except for notices
164c156
< variables_order               =       "GPCS"  ; This directive describes the order in which PHP re
gisters
---
> variables_order               =       "EGPCS" ; This directive describes the order in which PHP re
gisters
169c161
< register_globals      =       Off             ; Whether or not to register the EGPCS variables as
global
---
> register_globals      =       On              ; Whether or not to register the EGPCS variables as
global
175c167
< register_argc_argv    =       Off             ; This directive tells PHP whether to declare the ar
gv&argc
---
> register_argv_argc    =       Off             ; This directive tells PHP whether to declare the ar
gv&argc
184c176
< magic_quotes_gpc      =       Off             ; magic quotes for incoming GET/POST/Cookie data
---
> magic_quotes_gpc      =       On              ; magic quotes for incoming GET/POST/Cookie data
189,190c181,182
< auto_prepend_file     =
< auto_append_file      =
---
> auto_prepend_file     = /home/httpd/apache/auto_prepend.inc
> auto_append_file      = /home/httpd/apache/auto_append.inc
208,211d199
< enable_dl             = On                            ; Whether or not to enable the dl() function
.
<                                                                       ; The dl() function does NOT
 properly work in multithreaded
<                                                                       ; servers, such as IIS or Ze
us, and is automatically disabled
<                                                                       ; on them.
295,296d282
< mysql.default_socket  =               ; default socket name for local MySQL connects.  If empty, u
ses the built-in
<

Again, with the same ./configure switches and the same php.ini file, everything works with PHP 4.0.0, but not with 4.0.1 or 4.0.1pl2.

Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-04 12:34 UTC] stas at cvs dot php dot net
Does this error happen without auto_prepend and auto_append?
 [2000-08-08 08:26 UTC] stas@php.net
you probably didn't set doc_root. Please do so. 
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 16:00:02 2026 UTC