php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2901 php_value upload_tmp_dir is ignored
Submitted: 1999-12-03 06:02 UTC Modified: 2000-07-25 18:41 UTC
From: k at les dot cz Assigned:
Status: Closed Package: Other
PHP Version: 4.0 Beta 3 OS: Redhat Linux 6.0, 2.2.5 kernel
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: k at les dot cz
New email:
PHP Version: OS:

 

 [1999-12-03 06:02 UTC] k at les dot cz
If I put "php_value upload_tmp_dir some_dir into a config file of apache, it's ignored (phpinfo() reports "no value").

It works correctly only if I set it up in /usr/local/lib/php.ini

Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-23 02:01 UTC] zak at cvs dot php dot net
Contacting user for more information.

I am guessing that the user is running the CGI version of PHP - AFAIK, adding php directives inside the apache conf file when you are not running php_mod will only generate errors.

 [2000-07-25 18:19 UTC] zak@php.net
Bug Confirmed in 4.0.1pl2
I can set other values in my httpd.conf file using php_value or php_admin_value.

Here is my exact line:
php_admin_flag upload_tmp_dir /tmp

phpinfo () shows that upload_tmp_dir is set to 'no value'
 [2000-07-25 18:41 UTC] zak@php.net
Sorry - stupid user error on my part...
After using the correct directive of:
  php_admin_value upload_tmp_dir /tmp
upload_tmp_dir is set correctly...
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 11:00:01 2026 UTC