php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19276 Udefined symbol: core_globals
Submitted: 2002-09-07 08:02 UTC Modified: 2002-09-07 08:05 UTC
From: deadsman at hotmail dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.2.3 OS: redhat 7.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: deadsman at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-09-07 08:02 UTC] deadsman at hotmail dot com
Hi,
when I try to start apache whit php4 library, Apache 1.2.26 give me his error:

[root@lambda php-4.2.3]# apachectl start
Syntax error on line 205 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol: core_globals
/usr/sbin/apachectl start: httpd could not be started

The line for configuring apache and php is:

PHP:
./configure --with-mysql --with-apxs=/usr/sbin/apxs --with-config-file-path=/usr/local/lib/php --enable-dbase

APACHE:
./configure --with-layout=RedHat --enable-module=all --disable-module=auth_db --disable-module=auth_dbm

I have this problem whit other version of PHP like 4.2.1 and 4.2.2 .

Thx & Bye.

Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-07 08:05 UTC] kalowsky@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

Please read the Apache docs on how to add modules.
 [2002-09-07 08:14 UTC] deadsman at hotmail dot com
ok thx
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Thu Oct 08 00:00:02 2026 UTC