php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68333 import_request_variables() is still included and functioning after Upgrade
Submitted: 2014-10-31 10:20 UTC Modified: 2014-11-17 20:57 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: kraer_one at gmx dot net Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 5.4.34 OS: Debian Squeeze
Private report: No CVE-ID: None
View Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
If you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kraer_one at gmx dot net
New email:
PHP Version: OS:

 

 [2014-10-31 10:20 UTC] kraer_one at gmx dot net
Description:
------------
While porting a shopsystem to 5.4 I came across a lot of DEPRECATED Functions and ERRORS, so I removed them all at once.

BUT I did not receive ERRORS nor DEPRECATED messages whenever import_request_variables() is called.

That came across a bit wierd, cause I doublechecked the removed feature list.

I checked it on two servers with Debian Squeeze and DotDeb Repo PHP 5.4.34.
One as Fast CGI and one as Apache Mod.

Both accepted that removed feature.

Test script:
---------------
<?php
  ////////////////////////////////////////////
 // call script with FILENAME?test=krauts  //
////////////////////////////////////////////

echo $test;  // Will output nothing -> OK

import_request_variables("G"); // REMOVED feature since 5.4

echo $test; // Will output krauts -> Wrong ... previous line should result in an error.

// Just to make sure of php version >= 5.4
phpinfo();
?>


Expected result:
----------------
It should result in an ERROR because of the removed feature, but instead it just still works like it did in 5.3.

Actual result:
--------------
The removed function did NOT throw an ERROR nor did not function. It is like using 5.3

Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-31 17:52 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2014-10-31 17:52 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

I can't reproduce this on a clean Squeeze VM with php5 installed from dotdeb:

vagrant@debian-607-x64-vbox4210-nocm:~$ php -v
PHP 5.4.34-1~dotdeb.0 (cli) (built: Oct 23 2014 01:25:43)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
vagrant@debian-607-x64-vbox4210-nocm:~$ php -r 'import_request_variables('G');'
PHP Fatal error:  Call to undefined function import_request_variables() in Command line code on line 1

Given that there are no traces of import_request_variables (outside of unit tests) in the 5.4.34 tarball dotdeb use, nor in their patches, I'd say it's a problem with your environment.
 [2014-11-16 15:44 UTC] kraer_one at gmx dot net
Did some more checks, and the problem seem to result out of packagetreatments during the update, wich keeps parts of the old php still active on squeeze, after updating with dot-deb sources to 5.4.34.

On a clean Wheezy it could not be reproduced, since it ships with 5.4.34. So I am looking into the old files of php, wich still reside on the squeeze boxes after the upgrade.

This is not a bug within php!
It seem to be a bug within dpkg on debian or some other debian related packages.

Thanks for taking a look into this problem.
 [2014-11-17 20:57 UTC] kraer_one at gmx dot net
-Summary: import_request_variables() is still included and functioning +Summary: import_request_variables() is still included and functioning after Upgrade
 [2014-11-17 20:57 UTC] kraer_one at gmx dot net
Could not really figure out, which files really were the big problem. Cause I needed to get it up and running within a few minutes. But after purging (not only removing) all php relates files and reconfiguring it manually to my needs it works properly.

It's a problem when upgrading from old-stable Squeeze php5 offered by Debian via LTS repo with the DotDeb php5.4.34

So you might be better off purge php first and then clean install php from DotDeb.
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Tue Oct 06 12:00:01 2026 UTC