|
php.net | support | documentation | report a bug | advanced search | search howto | statistics | random bug | login |
PatchesPull RequestsHistoryAllCommentsChangesGit/SVN commits
[2000-08-17 03:20 UTC] sniper@php.net
[2000-08-29 18:26 UTC] sniper@php.net
|
|||||||||||||||||||||||||||
Copyright © 2001-2026 The PHP GroupAll rights reserved. |
Last updated: Sun Oct 11 07:00:02 2026 UTC |
Hi, I'm trying to use this with Postgres7.0 My configure is ./configure --with-pgsql=/usr/local/pgsql \ --without-mysql \ --with-apxs=/usr/local/apache/bin/apxs I've defined CFLAGS and LD_LIBRARY_PATH as follows: CFLAGS=-R/usr/local/pgsql/lib -I/usr/local/pgsql/include LD_LIBRARY_PATH=/usr/local/pgsql/lib The "make" and "make install" run without any problems, but I can't start apache. I've checked to ensure /usr/local/apache/libexec/libphp4.so is there, and with the correct permissions, but I still get this error pubaffairs# ./apachectl start Syntax error on line 207 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol PQfinish: referenced symbol not found ./apachectl start: httpd could not be started P.S. I tried compiling php3.0.16 and got the same error.