|
php.net | support | documentation | report a bug | advanced search | search howto | statistics | random bug | login |
[2002-08-21 09:41 UTC] rehman at rehman dot ch
I run php CGI 4.2.2 on two servers with IIS
on one everything is fine, on the hosting server
the exec command cant find any absolute filepath,
exec("sample.exe"); works
exec("c:\\inetpub\\wwwroot\\sample.exe"); fails without giving error messages!
on a third server it says "unable to fork"
I've tried a lot, the php.ini possible restriction settings are not involved I checked and since it is twice the same file, and in one case it works.
It must be some difference in the Server configuration. It also can't be the security settings as documented since the same file is once allowed once denied.
Im lost in this, does someone know about such problems? how to proceed to find the problem source?
PatchesPull RequestsHistoryAllCommentsChangesGit/SVN commits
|
|||||||||||||||||||||||||||
Copyright © 2001-2026 The PHP GroupAll rights reserved. |
Last updated: Wed Oct 07 11:00:02 2026 UTC |
I found out: exec using absolut paths seems to need rights not only on the file executed but on the whole path tree leading to it, which is not allways allowed by the hosters!!! I run php CGI 4.2.2 on two servers with IIS on one everything is fine, on the hosting server the exec command cant find any absolute filepath, exec("sample.exe"); works exec("c:\\inetpub\\wwwroot\\sample.exe"); fails without giving error messages! on a third server it says "unable to fork" I've tried a lot, the php.ini possible restriction settings are not involved I checked and since it is twice the same file, and in one case it works. It must be some difference in the Server configuration. It also can't be the security settings as documented since the same file is once allowed once denied. Im lost in this, does someone know about such problems? how to proceed to find the problem source?