php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #9648 Gettext does not work (id #8969)
Submitted: 2001-03-09 05:15 UTC Modified: 2001-07-21 16:05 UTC
From: stefan at devtrend dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.0 Latest CVS (09/03/2001) OS: Linux Slackware 7.1
Private report: No CVE-ID: None
 [2001-03-09 05:15 UTC] stefan at devtrend dot com
Regarding gettext won't translate strings (id #8969), I found that if you use:

putenv ("LC_ALL=sv");  // or any other language

instead of:

putenv ("LANG=sv");

it works perfekt.

I can't see it documented anywhere and I'm sure there are more than me who have stumbled into this problem..

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-09 06:27 UTC] sniper@php.net
putenv("LANG=sv"); 

works for me just fine on Red Hat 6.2.

--Jani

 [2001-07-21 16:05 UTC] andy@php.net
works fine on Red Hat 7
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 20:01:26 2019 UTC