php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8652 exec and system always return -1
Submitted: 2001-01-11 07:31 UTC Modified: 2001-05-11 21:11 UTC
From: simon dot king at pipinghotnetworks dot com Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.4 OS: RedHat Linux 6.2
Private report: No CVE-ID: None
 [2001-01-11 07:31 UTC] simon dot king at pipinghotnetworks dot com
<?

function run_command($command, $errmsg) {
  $lastline = exec("$command 2>&1", &$lines, $rc);
  if ($rc) {
    print("<pre>\n");
    print("$errmsg\n\n");
    print("Command  : $command\nReturned : $rc\nOutput\n------\n");
    print(join("\n", $lines)."\n\n");
  }
  return($rc);
}

$rc = run_command("/bin/uname -a", "Uname Failed!");

print("rc now = $rc");

?>

All the commands that I have tested (uname is just an example) have returned -1 as the return code, even though the command has executed perfectly well. I get the same error if I use system instead of exec. I cannot see how else to run a command and check to see whether it failed or not.

I am using PHP RPMS downloaded from http://rpms.arvin.dk/php/ but this does not seem like a packaging error, so I am reporting it here.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-15 08:45 UTC] cynic@php.net
duplicate of #8466
 [2001-05-11 21:11 UTC] sniper@php.net
Fixed in CVs.

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 00:01:25 2019 UTC