php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8465 Cannot exec, system, passthru, backticks
Submitted: 2000-12-28 17:27 UTC Modified: 2001-04-27 19:42 UTC
From: che at atlantic dot net Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.4 OS: Windows 2000 Server
Private report: No CVE-ID: None
 [2000-12-28 17:27 UTC] che at atlantic dot net
<?php
    print `echo hello world`;
?>

I have tried exec, backticks, system, passthru, and they all do not work.  When running the CGI version, there is no message displayed.  When running the isapi version, I get the error message "Warning: Unable to fork [echo hello world] in c:\inetpub\wwwroot\horus.atlantic.net\test.php on line 3".  It seems that this has been going on for a while now.  "CreateProcess" is a very simple Windows API call.  If PHP is going to beat ASP, this needs to be resolved.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-28 18:17 UTC] lyric@php.net
"echo" is not a command under windows, rather something built into the shell (cmd.exe). Hence the error message is correct - you can't run a command that doesn't exist. You should use something like "cmd /c echo hello world".

I'll do us both a favour and ignore your other comments
 [2001-01-03 11:11 UTC] derick@php.net
Duplicate of 4761
 [2001-04-27 19:42 UTC] sniper@php.net
This is fixed in CVS. Wait for PHP 4.0.6 to be released.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 07:01:25 2019 UTC