php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8263 com_invoke
Submitted: 2000-12-14 17:44 UTC Modified: 2001-01-30 04:36 UTC
From: behrooz at lycos dot com Assigned:
Status: Closed Package: COM related
PHP Version: 4.0.3pl1 OS: Windows 2000 Server
Private report: No CVE-ID: None
 [2000-12-14 17:44 UTC] behrooz at lycos dot com
On Windows 2000 server:

Any attempt to use com_invoke() returns this error message:

Fatal error: Call to undefined function: com_invoke() in ...

The COM object was tested, it works with VBScript from a Microsoft ASP with the same conditions.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-14 17:47 UTC] behrooz at lycos dot com
On Windows 2000 server:

Any attempt to use com_invoke() returns this error message:

Fatal error: Call to undefined function: com_invoke() in ...

The COM was tested, it works with VBScript from a Microsoft ASP with the same
conditions.

 [2000-12-14 18:00 UTC] derick@php.net
I had exactly the same problem, but I got the com objects to work with
this kind of syntax:

$obj = new COM ("name");

and call a method with:
$obj->method ($param1);

properties:
$obj->prop1 = "blagh";
 [2001-01-02 15:33 UTC] sniper@php.net
Duplicate of #8121

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 14:01:25 2019 UTC