php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81507 Fiber does not compile on AIX
Submitted: 2021-10-05 14:24 UTC Modified: 2021-11-04 09:52 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: etienne dot guesnet at atos dot net Assigned:
Status: Closed Package: Compile Failure
PHP Version: 8.1.0RC3 OS: AIX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: etienne dot guesnet at atos dot net
New email:
PHP Version: OS:

 

 [2021-10-05 14:24 UTC] etienne dot guesnet at atos dot net
Description:
------------
I cannot build PHP 7.1.0RC3 on AIX 7.1 due to a bug in Fiber part.

On 64 bits (-maix64 and OBJECT_MODE=64 used), host remains "powerpc-ibm-aix7.1.5.0", so "$fiber_os" is "ppc32", and 32 bits PPC asm is used "make_ppc32_sysv_xcoff_gas.S" (configure.ac, line 1200). Attempted behavior: if -maix64 used, 64 bits PPC asm used.

On 32 bits, file "make_ppc32_sysv_xcoff_gas.S" does not compile, due to all "(r1)", not supported by AIX assembly.


Patches

HcPcEgmp (last revision 2021-10-31 04:16 UTC by sample at email dot tst)

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-10-05 14:26 UTC] etienne dot guesnet at atos dot net
Is there a way to tag @NattyNarwhal?
 [2021-10-05 14:28 UTC] nikic@php.net
-Status: Open +Status: Feedback
 [2021-10-05 14:28 UTC] nikic@php.net
I'm not familiar with PowerPC or AIX, but this sounds like it's effectively doing a cross-compile, in which case you need to specify a correct --build triple. Similar to how you need to set --build=i686-linux-gnu when using -m32 on a 64-bit system. Does it work if you specify a powerpc64-* triple?
 [2021-10-11 07:58 UTC] etienne dot guesnet at atos dot net
-Status: Feedback +Status: Open
 [2021-10-11 07:58 UTC] etienne dot guesnet at atos dot net
Build in 64 bits works with host as powerpc64-ibm-aix. However, it is not an official target: powerpc-ibm-aix is both 32 and 64 bits. As an example, GCC is built on 32 and 64 bits on AIX with the same host build.

I confirm build in 32 bits is broken due to "make_ppc32_sysv_xcoff_gas.S", but the reason is more complex that I have expected. Our ASM expert will have a look.
 [2021-10-15 07:19 UTC] chigot dot c at gmail dot com
The following pull request has been associated:

Patch Name: Zend/asm: adjust XCOFF asm files for AIX assembler
On GitHub:  https://github.com/php/php-src/pull/7579
Patch:      https://github.com/php/php-src/pull/7579.patch
 [2021-10-31 04:16 UTC] sample at email dot tst
The following patch has been added/updated:

Patch Name: HcPcEgmp
Revision:   1635653799
URL:        https://bugs.php.net/patch-display.php?bug=81507&patch=HcPcEgmp&revision=1635653799
 [2021-11-04 09:52 UTC] nikic@php.net
-Summary: Fiber does not compile +Summary: Fiber does not compile on AIX
 [2021-11-04 09:55 UTC] git@php.net
Automatic comment on behalf of Helflym (author) and nikic (committer)
Revision: https://github.com/php/php-src/commit/cfe8a455a60c50132aa36eb8574ef07094434eba
Log: Fix bug #81507: Adjust XCOFF asm files for AIX assembler
 [2021-11-04 09:55 UTC] git@php.net
-Status: Open +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 02:03:36 2021 UTC