php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79021 SimpleXML not installed on 7.3 by default
Submitted: 2019-12-23 11:41 UTC Modified: 2019-12-23 13:01 UTC
From: php4fan at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 7.3.13 OS: debian 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php4fan at gmail dot com
New email:
PHP Version: OS:

 

 [2019-12-23 11:41 UTC] php4fan at gmail dot com
Description:
------------
---
From manual page: https://php.net/simplexml.installation
---

> This extension is enabled by default.

That is BULLSHIT.
On php 7.3, it is not enabled by default.

On debian, you need to install php-xml with "apt install php-xml".


Test script:
---------------
<?php

new SimpleXMLElement('<kjsdc/>');

Expected result:
----------------
empty output

Actual result:
--------------
Fatal error: Class 'SimpleXMLElement' not found in .....

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-23 13:01 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-12-23 13:01 UTC] cmb@php.net
SimpleXML is enabled by default for the source distribution of
php.net.  We cannot document distribution specifics.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 00:01:24 2020 UTC