php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78790 Uncaught ArgumentCountError: mysqli_get_client_info() expects exactly 0 paramet
Submitted: 2019-11-06 23:22 UTC Modified: 2019-11-11 13:35 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bugreports3 at gmail dot com Assigned: cmb (profile)
Status: Re-Opened Package: MySQLi related
PHP Version: master-Git-2019-11-06 (Git) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugreports3 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-11-06 23:22 UTC] bugreports3 at gmail dot com
Description:
------------
PHP Fatal error:  Uncaught ArgumentCountError: mysqli_get_client_info() expects exactly 0 parameters, 1 given in mysql_class.inc.php:972
Stack trace:
#0 /global_mysql_class.inc.php(972): mysqli_get_client_info(Object(mysqli))
#1 status.php(681): mysql_class->get_client_info()
#2 {main}
  thrown in mysql_class.inc.php on line 972
  
https://www.php.net/manual/en/mysqli.get-client-info.php

Procedural style
mysqli_get_client_info ( mysqli $link ) : string


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-07 07:53 UTC] cmb@php.net
-Status: Open +Status: Verified -Package: Scripting Engine problem +Package: MySQLi related
 [2019-11-07 07:53 UTC] cmb@php.net
Thanks for reporting.

It seems some other mysqli functions are affected as well.
 [2019-11-07 09:23 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2019-11-11 09:02 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=87fad8cdf0b978bb7dca5123cb77efd1449c0132
Log: Fix #78790: mysqli_get_client_info() expects exactly 0 parameters
 [2019-11-11 09:02 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2019-11-11 09:06 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=b0391c3e263fd40515fb30e5cdc8f0dfed0b65ec
Log: Revert "Fix #78790: mysqli_get_client_info() expects exactly 0 parameters"
 [2019-11-11 09:07 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened
 [2019-11-11 13:19 UTC] bugreports3 at gmail dot com
ArgumentCountError: mysqli_get_client_info() expects exactly 0 parameters, 1 given still exists including "mysqli_get_client_info(Object(mysqli))"  and also no change by https://git.php.net/?p=php-src.git;a=commitdiff;h=adcc35916ac775366a1949f6838c585be376d678

tried https://git.php.net/?p=php-src.git;a=snapshot;h=2804ea612779b89d3c62d974eb35783dd31f7dee;sf=tgz recently
 [2019-11-11 13:35 UTC] cmb@php.net
I had to revert the fix, because there are issues regarding the
usage of mysqli_get_client_info() without argument, which has been
supported before.  I'm waiting on feedback regarding this[1].

[1] <https://github.com/php/php-src/pull/4878#discussion_r344636434>
 [2019-11-27 22:30 UTC] bugreports3 at gmail dot com
still the same with fresh snapshot

8 hours ago 	 Dmitry Stogov	Fixed wrong parameteris order master 	commit | commitdiff | tree | snapshot (zip tar.gz)

FAILED: NOT ALL TESTS PASSED

[27-Nov-2019 23:26:17] AUTOTEST ERROR-HANDLER - code: '1024', msg: 'FAILED: custom/phpincludes_mysql.php - Exception - ArgumentCountError: mysqli_get_client_info() expects exactly 0 parameters, 1 given in /phpincludes/global_mysql_class.inc.php:929 Stack trace: #0 /phpincludes/global_mysql_class.inc.php(929): mysqli_get_client_info() #1 /autotests/custom/phpincludes_mysql.php(442): mysql_class->get_client_info() #2 /autotests/suite/custom.php(37): require('/w...') #3 /autotest.php(455): cl_custom_test() #4 {main}', file: '/cms/cms/autotests/suite/custom.php:42'
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 13:01:23 2019 UTC