php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78542 Broken presentation on talks.php.net
Submitted: 2019-09-15 10:27 UTC Modified: 2019-09-15 12:54 UTC
From: php-bugs at allenjb dot me dot uk Assigned:
Status: Verified Package: Website problem
PHP Version: Irrelevant OS: n/a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
28 + 40 = ?
Subscribe to this entry?

 
 [2019-09-15 10:27 UTC] php-bugs at allenjb dot me dot uk
Description:
------------
http://talks.php.net/show/vxml_php_2004

When attempting to go to the next slide, an XML error occurs:
XML_Parser: Invalid character at XML input line 9:20


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-15 12:21 UTC] cmb@php.net
-Status: Open +Status: Verified -Package: Unknown/Other Function +Package: Website problem
 [2019-09-15 12:21 UTC] cmb@php.net
It seems the problem is that the slide viewer expects UTF-8
encoded XML[1], but vxml_php_2004.xml is ISO-8859-1 encoded.

[1] <https://github.com/php/web-pres2/blob/4812e8393d9b9d6e9ae8139ae3374dafa3e392f0/XML_Slide.php#L79>
 [2019-09-15 12:54 UTC] cmb@php.net
I'd gladly provide a PR for web-presentations, but I can't
checkout the repo[1] due to slides/grown-up/suhosin_gross.png?w=
containing a question mark.  It seems this file had been
inadvertently checked in.

[1] <http://git.php.net/?p=presentations.git;a=summary>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 04:01:33 2019 UTC