php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78145 Use curl get contents from url that can not be reached, crashed.
Submitted: 2019-06-11 15:10 UTC Modified: 2019-06-14 09:18 UTC
From: happycock at 163 dot com Assigned: cmb (profile)
Status: Not a bug Package: cURL related
PHP Version: 7.3.6 OS: macOS Mojave
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
45 - 10 = ?
Subscribe to this entry?

 
 [2019-06-11 15:10 UTC] happycock at 163 dot com
Description:
------------
Use curl get contents from url that can not be reached, crashed.

Test script:
---------------
<?php

$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, "a");
$return = curl_exec($ch);
curl_close($ch);

Actual result:
--------------
Segmentation fault: 11

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-11 15:25 UTC] nikic@php.net
-Status: Open +Status: Feedback
 [2019-06-11 15:25 UTC] nikic@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
 [2019-06-13 14:55 UTC] happycock at 163 dot com
-Status: Feedback +Status: Open
 [2019-06-13 14:55 UTC] happycock at 163 dot com
* thread #1, stop reason = signal SIGSTOP
  * frame #0: 0x000000010532afe0 libcurl.4.dylib`sh_delentry + 40
    frame #1: 0x000000010532afa9 libcurl.4.dylib`Curl_multi_closed + 122
    frame #2: 0x00000001072d6252 libcares.2.dylib`ares__close_sockets + 222
    frame #3: 0x00000001072de9fd libcares.2.dylib`end_query + 307
    frame #4: 0x00000001072df31c libcares.2.dylib`process_answer + 1374
    frame #5: 0x00000001072ddef3 libcares.2.dylib`processfds + 1428
    frame #6: 0x000000010533f963 libcurl.4.dylib`waitperform + 244
    frame #7: 0x000000010533f77c libcurl.4.dylib`Curl_resolver_is_resolved + 55
    frame #8: 0x000000010532a4e5 libcurl.4.dylib`multi_runsingle + 2645
    frame #9: 0x0000000105329995 libcurl.4.dylib`curl_multi_perform + 133
    frame #10: 0x000000010532349e libcurl.4.dylib`curl_easy_perform + 369
    frame #11: 0x0000000103edf20c php`zif_curl_exec + 100
    frame #12: 0x000000010768a19f xdebug.so`xdebug_execute_internal + 735
    frame #13: 0x0000000104219455 php`ZEND_DO_FCALL_SPEC_RETVAL_USED_HANDLER + 372
    frame #14: 0x00000001041e8c7c php`execute_ex + 98
    frame #15: 0x0000000107689bd4 xdebug.so`xdebug_execute_ex + 1332
    frame #16: 0x00000001041e8df8 php`zend_execute + 318
    frame #17: 0x00000001041ad972 php`zend_execute_scripts + 277
    frame #18: 0x0000000104159729 php`php_execute_script + 637
    frame #19: 0x0000000104258ae1 php`do_cli + 3855
    frame #20: 0x0000000104257a68 php`main + 1229
    frame #21: 0x00007fff7bd193d5 libdyld.dylib`start + 1
 [2019-06-14 03:18 UTC] happycock at 163 dot com
-Status: Open +Status: Closed
 [2019-06-14 03:18 UTC] happycock at 163 dot com
This is a bug of curl 7.65.1

$ bin/curl a
Segmentation fault: 11
 [2019-06-14 09:18 UTC] cmb@php.net
-Status: Closed +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-06-14 09:18 UTC] cmb@php.net
Please report upstream, if not already done.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 18:01:24 2019 UTC