php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77425 Operator error
Submitted: 2019-01-07 16:56 UTC Modified: 2019-01-07 17:07 UTC
From: karolyizoltan dot 1 at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 7.1.25 OS: Windows 8.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: karolyizoltan dot 1 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-01-07 16:56 UTC] karolyizoltan dot 1 at gmail dot com
Description:
------------
SYSTEM
I test here by PHP 7.2.4 as well: http://sandbox.onlinephpfunctions.com/
and on my desktop 7.1.25 (this come from the php is downloaded and installed from here: https://www.apachefriends.org/download.html)

PROBLEM
The same values in case of some operators do not result the right outcomes. All of the six cases need to be true but first four return false values.

Test script:
---------------
$a = '0.9';
$b = '7.34';
$c = '100';
$d = floor(($a * $b)*100)/100;
$e = $c + $b - $d;//this return 100.74 too
$f = 100.74;

// values of variables
var_dump($e);
var_dump($f);

//first four return false values but all of them need to be true
var_dump($e == $f);//false
var_dump($e <= $f);//false
var_dump($f >= $e);//false
var_dump($e == $f);//false
var_dump($e >= $f);//true
var_dump($f <= $e);//true

Expected result:
----------------
All the equations need to return true value for the same numbers.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-07 17:04 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-01-07 17:04 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 [2019-01-07 17:07 UTC] peehaa@php.net
To expend on the above please read the hard to miss big red warning on the Floating point numbers documentation page:

http://php.net/manual/en/language.types.float.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Aug 06 08:01:26 2020 UTC