php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77410 Segmentation Fault when executing method with an empty parameter
Submitted: 2019-01-04 10:37 UTC Modified: 2019-01-04 11:31 UTC
From: brother at bsnet dot se Assigned: nikic (profile)
Status: Closed Package: SOAP related
PHP Version: 7.3.0 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: brother at bsnet dot se
New email:
PHP Version: OS:

 

 [2019-01-04 10:37 UTC] brother at bsnet dot se
Description:
------------
When moving from PHP 7.2 to PHP 7.3 we noticed crashes in our SOAP communication. By crafting a smaller WSDL and test script we've narrowed it down to GC_PROTECT_RECURSION but can not really trace it further ourselves.

We've confirmed it on debian, centos and alpine packages. However it seems to work as intended (no crash) on Mac OS.

Also tried 7.3.1 RC1.

Test script:
---------------
schema.wsdl, php test script and gdb back trace:
https://gist.github.com/brother/f646c9f38816ca4c60980fe56ed2d249

Actual result:
--------------
Segmentation fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-04 11:31 UTC] nikic@php.net
-Assigned To: +Assigned To: nikic
 [2019-01-04 11:41 UTC] nikic@php.net
Automatic comment on behalf of nikita.ppv@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=361d3ede9394d03defba64237628e6b1a0a2a16b
Log: Fix bug #77410
 [2019-01-04 11:41 UTC] nikic@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 03:01:25 2020 UTC