php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #77356 ITS: Prevent marking tickets as duplicates without specifying original report
Submitted: 2018-12-27 04:53 UTC Modified: 2018-12-27 11:52 UTC
From: chealer at gmail dot com Assigned:
Status: Open Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2018-12-27 04:53 UTC] chealer at gmail dot com
Description:
------------
I noticed a few tickets marked as duplicates without any indication of which tickets they would duplicate. For instance, the following 2 tickets have their Status field set to Duplicate, but the Related reports tab is empty:
https://bugs.php.net/bug.php?id=60024
https://bugs.php.net/bug.php?id=62132

As this is the result of changes by 2 developers, it looks like this is not exceptional, and would deserve a change in the system so developers cannot mark a ticket as duplicate when failing to specify a related ticket tracking the same issue.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-27 10:54 UTC] cmb@php.net
Just to explain how that currently works: if a user refers to some
other ticket using “bug hash number”, the other ticket
automatically gets an entry “Related To: Bug hash number”.  These
entries can be filtered via the related reports “button”.  See,
for instance, <https://bugs.php.net/77347>, which has been closed
as duplicate of <https://bugs.php.net/77278>.  Only the latter has
a filterable related reports entry.  So, basically no duplicate is
presently supposed to show any related reports.

Also, there is a problem regarding comments which contain
inadvertant referrals to other tickets.  See, for instance,
<https://bugs.php.net/2307> which claims to be related to
<https://bugs.php.net/77349> which it is certainly not.

> […] and would deserve a change in the system so developers
> cannot mark a ticket as duplicate when failing to specify a
> related ticket tracking the same issue.

Hmm, that would require advanced AI, wouldn't it?

Anyhow, I suggest to move the discussion regarding possible
improvements of referrals and duplicates to the php-webmaster@
mailing list, since a bug tracker is unsuitable for brainstorming,
which is certainly necessary in this case.
 [2018-12-27 11:52 UTC] chealer at gmail dot com
Ah, thank you for the explanation cmb, I see what you mean but I did not mean to suggest using any artificial intelligence, no. Sorry, I misunderstood how Related reports works.

I was rather suggesting a field to explicitly define the report with which a duplicate is redundant, as Bugzilla does:
https://www.tutorialspoint.com/bugzilla/bugzilla_duplicate.htm
https://bugzilla.mozilla.org/show_bug.cgi?id=548960

This field would appear when the Status field would be set to the value Duplicate. It would also allow other improvements to duplicate handling, like managing those who subscribe to a ticket automatically.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 09:01:27 2019 UTC