php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77341 SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES returns wrong value.
Submitted: 2018-12-23 04:58 UTC Modified: 2018-12-23 05:16 UTC
From: Scott dot Grosch at icloud dot com Assigned:
Status: Not a bug Package: *Encryption and hash functions
PHP Version: 7.3.0 OS: macOS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Scott dot Grosch at icloud dot com
New email:
PHP Version: OS:

 

 [2018-12-23 04:58 UTC] Scott dot Grosch at icloud dot com
Description:
------------
The source for libsodium defines crypto_aead_chacha20poly1305_ietf_NPUBBYTES as 12U.  However, using php when I print out the value of SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES it comes back as 8, not 12.

Test script:
---------------
echo SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES . "\n";


Expected result:
----------------
Should print out 12, no 8


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-23 05:07 UTC] Scott dot Grosch at icloud dot com
I'm sorry, please close this bug.  I was missing the _IETF_ part on the PHP side.
 [2018-12-23 05:16 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-12-23 05:16 UTC] requinix@php.net
.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 03:01:27 2019 UTC