php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #77292 Please provide PECL Solr extension for PHP 7.2
Submitted: 2018-12-13 09:13 UTC Modified: 2019-07-15 21:33 UTC
Votes:7
Avg. Score:5.0 ± 0.0
Reproduced:7 of 7 (100.0%)
Same Version:6 (85.7%)
Same OS:3 (42.9%)
From: eyesee at foobarlab dot net Assigned: omars (profile)
Status: Closed Package: solr (PECL)
PHP Version: 7.2.13 OS: Linux 64-bit
Private report: No CVE-ID: None
 [2018-12-13 09:13 UTC] eyesee at foobarlab dot net
Description:
------------
Since more than a year ago as reported earlier[1] there was a patch submitted[2] to make the PHP PECL Solr extension compatible with PHP 7.2. It would be nice if this could be made available on the PECL website[3]. Thanks!

[1] https://bugs.php.net/bug.php?id=74736

[2] https://git.php.net/?p=pecl/search_engine/solr.git;a=commit;h=744e32915d5989101267ed2c84a407c582dc6f31

[3] https://pecl.php.net/package/solr

Test script:
---------------
<Install PECL Solr extension in PHP 7.2.13>

Expected result:
----------------
<PECL Solr extension in PHP 7.2.13 compiles and works>

Actual result:
--------------
<PECL Solr extension in PHP 7.2.13 fails to compile>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-29 09:31 UTC] omars@php.net
-Assigned To: +Assigned To: omars
 [2019-07-15 21:33 UTC] omars@php.net
-Status: Assigned +Status: Closed
 [2019-07-15 21:33 UTC] omars@php.net
released: 2.5.0
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 05:01:26 2019 UTC