php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77265 No SSH2 extension support
Submitted: 2018-12-07 23:02 UTC Modified: 2019-01-24 16:26 UTC
Votes:5
Avg. Score:4.8 ± 0.4
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:0 (0.0%)
From: kevin at icscomp dot com Assigned:
Status: Open Package: ssh2 (PECL)
PHP Version: 7.3.0 OS: Windows 2012 Server
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2018-12-07 23:02 UTC] kevin at icscomp dot com
Description:
------------
We are stuck on PHP 7.1 with no stable SSH2 extension in the PECL repository.

Since PHP has direct documentation for using PHP with a number of SSH functions, it is strange that this isn't being kept up.  I also wonder why this isn't a standard extention in PHP since the base php download contains the libssh2.dll.  But you cannot actually use the functions without the extension in PECL.

Thanks,

Kevin

Expected result:
----------------
To be able to use the functionality found here: 

http://php.net/manual/en/book.ssh2.php

Actual result:
--------------
No functionality because no extension is found compatible with any current version of PHP.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-08 10:10 UTC] cmb@php.net
-Package: Unknown/Other Function +Package: ssh2
 [2018-12-08 10:57 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2018-12-08 10:57 UTC] cmb@php.net
> We are stuck on PHP 7.1 with no stable SSH2 extension in the
> PECL repository.

Well, there are DLLs of PECL/ssh2 1.1.2 available for PHP 7.0, 7.1
and 7.2.  1.1.2 doesn't work with PHP 7.3, but it seems these
issues have already been resolved in the repo[1], so maybe just a
new release is missing.

> I also wonder why this isn't a standard extention in PHP since
> the base php download contains the libssh2.dll.

libssh2.dll is required by CURL and maybe other bundled extensions.

[1] <http://git.php.net/?p=pecl/networking/ssh2.git;a=commit;h=a8835aab2c15e794fce13bd927295719e384ad2d>
 [2018-12-08 12:30 UTC] kevin at icscomp dot com
Yes, now PHP 7.2 is listed, PHP 7.3 is the only one unavailable.

However, there is no stable build as all of the PHP 7.x builds show on the PECL sitr as ALPHA.
 [2018-12-08 23:47 UTC] ab@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: ab
 [2018-12-08 23:47 UTC] ab@php.net
Hi,

yeah, I worked yesterday on some fix to the OpenSSL 1.1.x compatibility, so the latest 7.2 compatible release could be built. For 7.3, the current master seems at least to build, but it's not released yet. Please fetch the latest master snapshots here https://windows.php.net/downloads/pecl/snaps/ssh2/1.2-dev/ . With this, the Windows builds availability question should be solved. Other things like the release cycle of ext/ssh2 are out of scope of this ticket.

Thanks.
 [2018-12-10 18:28 UTC] kevin at icscomp dot com
-Status: Closed +Status: Assigned
 [2018-12-10 18:28 UTC] kevin at icscomp dot com
While using the snapshot version does give me something to start working with, I'd like to know the extension I'm using is in a stable version before conversion in production.

If asking when a stable build for this extension in PHP 7.3 is out of the scope of this bug ticket, where should I inquire about this?
 [2018-12-10 18:49 UTC] ab@php.net
-Status: Assigned +Status: Open -Assigned To: ab +Assigned To:
 [2018-12-10 18:49 UTC] ab@php.net
The snapshot availability can sure help to catch something. What I meant, a new release can be only triggered by ext/ssh2 leads, after enough QA also on other platforms, which is indeed out of scope of this ticket. Though, it's of course fine to keep this ticket open till a new version is released.

Thanks.
 [2018-12-11 14:59 UTC] spam2 at rhsoft dot net
just use curl with supports SSH2 besides a lot of other stuff in rely in pecl-extensions, these have to be avoided whereever you can because they may or may not be maintained and there is not hint at dead ones

https://pecl.php.net/package/GDChart
do you see here any notice that it's unsopported for nearly a decade?
 [2018-12-11 15:53 UTC] perske at uni-muenster dot de
The problem affects not only Windows but Linux, too.

Remi offers CentOS RPM packets for PHP 7.3 including SSH2 extension.

The source RPMs contain two patches that need to be applied to ssh2-1.1.2 to make that extension compatible to PHP 7.3

See https://rpms.remirepo.net/SRPMS/repoview/php-pecl-ssh2.html
 [2019-01-24 16:26 UTC] kevin at icscomp dot com
When will the PECL extension become officially available on the PECL site?  7.2 is still the only one out there.  Furthermore, it still is listed as "Alpha".  I have downloaded the one from the master repo as mentioned before, but it would be helpful to know that there is a "production" ready version that is available to use.  Is there another group I should be contacting?
 [2019-03-12 20:04 UTC] william dot vanevhevelingen at acquia dot com
How do we get the attention of the ext/ssh2 leads to request a new release that includes this change?
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 10:01:26 2019 UTC