php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77078 Error message should be clearer when cairo library missing
Submitted: 2018-10-29 12:10 UTC Modified: 2018-10-29 15:31 UTC
From: teo8976 at gmail dot com Assigned:
Status: Not a bug Package: cairo (PECL)
PHP Version: 7.2.11 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: teo8976 at gmail dot com
New email:
PHP Version: OS:

 

 [2018-10-29 12:10 UTC] teo8976 at gmail dot com
Description:
------------
I'm trying to install pecl/cairo with

# pecl install cairo-0.3.2

and I get an error that says that cairo is not found in the system. Brilliant.

Test script:
---------------
From the command line:

# pecl install cairo-0.3.2


Expected result:
----------------
should either install, or tell me exactly what's wrong that causes the installation to fail

Actual result:
--------------
The output ends with this error:

  checking for cairo... not found
  configure: error: Ooops ! no cairo detected in the system
  ERROR: `/tmp/pear/temp/Cairo/configure --with-php-config=/usr/bin/php-config --with-cairo' failed

Yeah, of course no cairo detected in the system, that's the very thing I'm trying to install, you idiot!!


Full output below:




# pecl install cairo-0.3.2
WARNING: channel "pecl.php.net" has updated its protocols, use "pecl channel-update pecl.php.net" to update
downloading Cairo-0.3.2.tgz ...
Starting to download Cairo-0.3.2.tgz (173,203 bytes)
.....................................done: 173,203 bytes
23 source files, building
running: phpize
Configuring for:
PHP Api Version:         20131106
Zend Module Api No:      20131226
Zend Extension Api No:   220131226
Please provide the prefix of the Cairo installation [autodetect] : 
building in /tmp/pear/temp/pear-build-rootHMTcLo/Cairo-0.3.2
running: /tmp/pear/temp/Cairo/configure --with-php-config=/usr/bin/php-config --with-cairo
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib
checking for PHP extension directory... /usr/lib/php5/20131226
checking for PHP installed headers prefix... /usr/include/php5
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for Cairo graphics library support... yes, shared
checking PHP version... ok
checking for pkg-config... found
checking for cairo... not found
configure: error: Ooops ! no cairo detected in the system
ERROR: `/tmp/pear/temp/Cairo/configure --with-php-config=/usr/bin/php-config --with-cairo' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-29 15:05 UTC] salathe@php.net
-Status: Open +Status: Not a bug
 [2018-10-29 15:05 UTC] salathe@php.net
The PECL cairo package depends on the cairo graphics library. Instructions for installing the latter can be found at https://www.cairographics.org/download/
 [2018-10-29 15:31 UTC] teo8976 at gmail dot com
-Summary: Trying to install cairo, says cairo not found +Summary: Error message should be clearer when cairo library missing -Type: Documentation Problem +Type: Bug
 [2018-10-29 15:31 UTC] teo8976 at gmail dot com
Yeah, later I realised.

The error message should still be clearer, though.

Please reopen, I have edited the title
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Mar 25 06:01:27 2019 UTC